Some Windows 10 Apps Failing on start

10

I just installed Windows 10 final release and noticed some apps including Store, Photos and Groove Music are not working.

Trying to open photos in this case

After digging around the Internet I've tried addressing the problem with the following command line:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

However it looks like it made it worse, and it now shows this error on the apps that aren't working:

Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered.
Merge Failure : error 0x80070003 : Cannot register the Microsoft.Windows.Photos_15.721.12350.0_x64__8wekyb3d8bbwe
package because there was a merge failure with the following file: C:\Program
Files\WindowsApps\Microsoft.Windows.Photos_15.721.12350.0_neutral_split.language-ru_8wekyb3d8bbwe\resources.pri
NOTE: For additional information, look for [ActivityId] a158907a-ceee-0007-8cba-58a1eeced001 in the Event Log or use
the command line Get-AppxLog -ActivityID a158907a-ceee-0007-8cba-58a1eeced001
At line:1 char:38
+ ...  | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : WriteError: (C:\Program File...ppXManifest.xml:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

I noticed the "ru" in "Microsoft.Windows.Photos_15.721.12350.0_neutral_split.language-ru_8" so I removed my Russian keyboard input to see if that could fix the problem but nothing happened. My configuration is English by default and United States is set to my location. Also I have got the latest updates.

I tried running the App Store Troubleshooter but it won't run:

Troubleshooter won't work on Windows 10 even though is from Win10 page

Right now the affected apps are looking like this:

Even menu changed after running the command above

Finally, I haven't done anything hacky on my system, so I suspect it has to do with the language. I have Spanish, Russian, and English keyboard inputs.

Note: On fresh install account the apps work fine. But it would be to much for me to migrate everything.

windows
windows-10
asked on Super User Aug 7, 2015 by user479706 • edited Oct 26, 2016 by 3498DB

1 Answer

1

After some research, I found out that it may trying to merge with the wrong resource file.

First of all, open Command Prompt with admin privileges and do chkdsk /f /r, restart so Windows can check the file system and then try to run the Add-AppxPackage command again after it is done.

If that doesn't work, I found a similar question in another forum with some things you can try, and see if any of that will work, I will quote them here:

Quote from Deason Wu's answer:

Manually deleting the app directory inside the AppData folder

Changing default owner of registry key to system

HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages

Please backup these folders or registry entries before taking any action.

Quote from ctp Han Solo's answer:

What I'd like to add is that I belive the cause is that when resintalling WindowsStore

add-appxpackage -register "C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.25.5.0_x64__8wekyb3d8bbwe\AppxManifest.xml" -disabledevelopmentmode

It tries, and fails, to merge with:

C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.25.5.0_neutral_split.language-es_8wekyb3d8bbwe\resources.pri

Because this version doesn't exist. The one that exists is:

C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.7.1.0_neutral_split.language-es_8wekyb3d8bbwe

So probably it is the resource file that for some unknown reason, Windows is trying to merge with the wrong file, so deleting the app folder and try to reinstall all over again may work.

Another thing I want to add is that you tried to used the "Add-AppxPackage" command first. Try to run Remove-AppxPackage on that specific AppxPackage and then try to add again (more info here). Be sure you are running the PowerShell as Administrator for those commands.

If still doesn't fix your problem, open your command prompt with admin privs and do dism /online /cleanup-image /restorehealth. Note that it can take a lot of time to complete.

Finally, if none of that works, you can try to use that another user account, move your personal files to that account, remove the old one and link your newly created account to your Microsoft Account to use their services, or reinstall Windows using the Settings > Update & Security > Recovery > Reset this PC option. You can choose to save your files and configurations, but it will reset your Windows, so your installed softwares are going to be deleted. I searched all around for some time already and couldn't find anything more than these steps fix this issue, I will update this answer if I find anything new.

answered on Super User Jan 12, 2016 by axys93

User contributions licensed under CC BY-SA 3.0