The sims 4 has stopped working on launch but works without power service on clean boot

0

enter image description here

Here's what I've done:

  • I tried re-installing everything
  • All display drivers are up to date, directx etc
  • I don't use any mods or CC
  • I have tuned off DEP
  • I included all sims 4 exe files into antivirus/firewall/defender exception list
  • -the last thing I tried was clean boot and it worked, BUT after finding the culprit which is Power service in msconfig. Turned out I couldn't control power options, screen brightness (it became very dark by default), and audio services can't be enabled I don't want to play sims without audio and a dark screen so please help me out I'm desperate for some answer

I've downloaded sims 4 long ago on the same device and everything worked perfectly so I have no idea what went wrong this time

This is from event viewer:

Faulting application name: TS4_x64.exe, version: 1.62.67.1020, time stamp: 0x5e798db8
Faulting module name: atiumd64.dll, version: 26.20.15029.27016, time stamp: 0x5e9f589b
Exception code: 0xc0000005
Fault offset: 0x0000000000114399
Faulting process id: 0x128c
Faulting application start time: 0x01d632b5b2947bd7
Faulting application path: D:\games\TS4 SIMITUP\The Sims 4\Game\Bin\TS4_x64.exe
Faulting module path: C:\Windows\system32\atiumd64.dll
Report Id: f27702a3-9ea8-11ea-82e2-d07e352af692
windows-7
services
gaming
asked on Super User May 25, 2020 by Nightmare Grimoire • edited May 25, 2020 by Tetsujin

0 Answers

Nobody has answered this question yet.


User contributions licensed under CC BY-SA 3.0