Virtual box is not working on windows 10

5

I have installed virtual box But when I tried to run it. It shows me an error as:

enter image description here

I have been trying everything for whole day. Like there are answers related to this question as:

VT-x is not available, but is enabled in BIOS VT-x is not available (VERR_VMX_NO_VMX) (VirtualBox) but enabled in bios, hyper-v enabled, and cpu supported

But nothing seems to work out in my case. I want to install ubuntu18.04 on VM.

These are my logs:

00:00:02.822701 VirtualBox VM 6.0.0 r127566 win.amd64 (Dec 18 2018 12:01:23) release log
00:00:02.822732 Log opened 2019-01-08T10:02:05.773237700Z
00:00:02.822733 Build Type: release
00:00:02.822737 OS Product: Windows 10
00:00:02.822738 OS Release: 10.0.17134
00:00:02.822739 OS Service Pack: 
00:00:02.902704 DMI Product Name: 20L6S4T80H
00:00:02.907611 DMI Product Version: ThinkPad T480
00:00:02.907624 Host RAM: 16262MB (15.8GB) total, 11912MB (11.6GB) available
00:00:02.907627 Executable: C:\Program Files\Oracle\VirtualBox\VirtualBoxVM.exe
00:00:02.907627 Process ID: 12160
00:00:02.907628 Package type: WINDOWS_64BITS_GENERIC
00:00:02.909800 Installed Extension Packs:
00:00:02.909899   None installed!
00:00:02.911165 Console: Machine state changed to 'Starting'
00:00:02.911757 Qt version: 5.6.2
00:00:02.915484 GUI: UIMediumEnumerator: Medium-enumeration finished!
00:00:03.057646 SUP: Loaded VMMR0.r0 (C:\Program Files\Oracle\VirtualBox\VMMR0.r0) at 0xXXXXXXXXXXXXXXXX - ModuleInit at XXXXXXXXXXXXXXXX and ModuleTerm at XXXXXXXXXXXXXXXX using the native ring-0 loader
00:00:03.057680 SUP: VMMR0EntryEx located at XXXXXXXXXXXXXXXX and VMMR0EntryFast at XXXXXXXXXXXXXXXX
00:00:03.057687 SUP: windbg> .reload /f C:\Program Files\Oracle\VirtualBox\VMMR0.r0=0xXXXXXXXXXXXXXXXX
00:00:03.062104 Guest OS type: 'Ubuntu_64'
00:00:03.064007 fHMForced=true - Lots of RAM
00:00:03.064022 fHMForced=true - 64-bit guest
00:00:03.070587 File system of 'C:\Users\hichaudh\Downloads\ubuntu-18.04.1-desktop-amd64.iso' (DVD) is ntfs
00:00:03.075516 File system of 'C:\Users\hichaudh\VirtualBox VMs\Ubuntu\Snapshots' (snapshots) is unknown
00:00:03.075531 File system of 'C:\Users\hichaudh\VirtualBox VMs\Ubuntu\Ubuntu.vdi' is ntfs
00:00:03.112825 Shared clipboard service loaded
00:00:03.112847 Shared clipboard mode: Off
00:00:03.137749 Drag and drop service loaded
00:00:03.137761 Drag and drop mode: Off
00:00:03.139869 ************************* CFGM dump *************************
00:00:03.255048 NEM:                             ShaSupport: 0
00:00:03.255052 NEM:                X87PointersSavedSupport: 0
00:00:03.255089 NEM: WHvCapabilityCodeProcessorClFlushSize = 2^8
00:00:03.256588 NEM: VidGetHvPartitionId            -> fun:0x2210a3 in:0x0 out:0x8
00:00:03.256618 NEM: VidStartVirtualProcessor       -> fun:0x22115c in:0x4 out:0x0
00:00:03.256623 NEM: VidStopVirtualProcessor        -> fun:0x221168 in:0x4 out:0x0
00:00:03.256635 NEM: VidMessageSlotHandleAndGetNext -> fun:0x2210cb in:0xc out:0x0
00:00:03.256722 VMSetError: F:\tinderbox\win-rel\src\VBox\VMM\VMMR3\NEMR3Native-win.cpp(1298) int __cdecl nemR3NativeInit(struct VM *,bool,bool); rc=VERR_NEM_MISSING_KERNEL_API
00:00:03.256907 VMSetError: 
00:00:03.256936 NEM: NEMR3Init: Native init failed: VERR_NEM_MISSING_KERNEL_API.
00:00:03.256946 VMSetError: F:\tinderbox\win-rel\src\VBox\VMM\VMMR3\HM.cpp(818) int __cdecl HMR3Init(struct VM *); rc=VERR_VMX_NO_VMX
00:00:03.256974 VMSetError: VT-x is not available
00:00:03.258928 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={872da645-4a9b-1727-bee2-5585105b9eed} aComponent={ConsoleWrap} aText={ (VERR_NEM_MISSING_KERNEL_API).
00:00:03.259018 VT-x is not available (VERR_VMX_NO_VMX)}, preserve=false aResultDetail=-4009
00:00:03.259562 Console: Machine state changed to 'PoweredOff'
00:00:03.266129 Power up failed (vrc=VERR_VMX_NO_VMX, rc=E_FAIL (0X80004005))
00:00:03.767441 GUI: UIMachineViewNormal::resendSizeHint: Restoring guest size-hint for screen 0 to 800x600
00:00:03.767486 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={ab4164db-c13e-4dab-842d-61ee3f0c1e87} aComponent={DisplayWrap} aText={The console is not powered up}, preserve=false aResultDetail=0
00:00:03.767731 GUI: Aborting startup due to power up progress issue detected...

Note:

  • I have checked my BIOS VT-x is enabled.
  • Hyper-V is disabled from windows features.
  • Windows virtualization is enabled from windows features.

Any help !

windows-10
virtualbox
virtual-machine
bios
virtualization
asked on Super User Jan 8, 2019 by Himanshu

3 Answers

9

I have figured it out after giving my whole Day. There are other settings too in windows which needs to be figured out when working with VM. We need to disable Windows Hypervisor Platform along with Hyper-V.

enter image description here

Since I have installed docker desktop on windows due to which these setting are enabled. Also you need to restart after changing these settings.

answered on Super User Jan 8, 2019 by Himanshu
4

from windows features, I disabled a number of features, retrying each time. I disabled the following:

  • Hyper-V
  • Virtual Machine Platform
  • Windows Hypervisor platform
  • Container

Hope that helps someone

answered on Super User Sep 20, 2019 by user1092306
0

I have similar problem. Then I found it out that Windows Defender Application Guard also needs to be disabled and then my VM runs well.

answered on Super User Feb 16, 2019 by Jason Huang

User contributions licensed under CC BY-SA 3.0