Failed binding - not looking in bin directory

0

I have a website that refuses to find system.net.http. The version/signature it uses is included in the bin directory. I ran fusion to capture bindings, and listed it below - anybody know why it is giving up after not finding it in the GAC? Shouldn't it move on to the /bin directory in c:/Mywebsite.TEST/Home/bin?

*** Assembly Binder Log Entry  (8/18/2020 @ 4:14:31 PM) ***

The operation failed.
Bind result: hr = 0x80070002. The system cannot find the file specified.

Assembly manager loaded from:  C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
Running under executable  c:\windows\system32\inetsrv\w3wp.exe
--- A detailed error log follows. 

=== Pre-bind state information ===
LOG: DisplayName = System.Net.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
 (Fully-specified)
LOG: Appbase = file:///C:/Mywebsite.TEST/Home/
LOG: Initial PrivatePath = NULL
LOG: Dynamic Base = NULL
LOG: Cache Base = NULL
LOG: AppName = ed827e2
Calling assembly : (Unknown).
===
LOG: This bind starts in default load context.
LOG: Using application configuration file: C:\Mywebsite.TEST\Home\web.config
LOG: Using host configuration file: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet.config
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework64\v4.0.30319\config\machine.config.
LOG: GAC Lookup was unsuccessful.
ERR: No codebases found to download from.
ERR: Unrecoverable error occurred during pre-download check (hr = 0x80070002).
c#
dll
fusion
asked on Stack Overflow Aug 18, 2020 by John Hennesey

0 Answers

Nobody has answered this question yet.


User contributions licensed under CC BY-SA 3.0