80040154 Class not registered

0

We have an old asp.net website built in 32-bit platform using .net framework 2.0. This asp.net website is using a 3rd party com dll(testx.dll) along with interop dll(testx.Interop.dll) for one functionality. And the code to access this dll was written in the cs file which is in the App_Code folder in the project. This has been deployed to 32-bit windows server 2008 and everything is working fine here.

Now We are upgrading this application to .net framework 4.7.1 with the target platform as a 64-bit machine. And This we need to deploy in 64-bit Windows server 2016.

I have registered successfully the testx.dll as below and could see the entry under Wow6432Node in the registry, regsvr32 ..\testX.dll

I am facing the below issue while trying to access a class in Com dll in my local machine with VS2015. I also tried by changing the target platform from Any CPU to x86 but got the same issue.

"Retrieving the COM class factory for component with CLSID {D00D7FB0-5997-11D4-8153-00E07D01A2E0} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))."

And surprisingly Everything is working fine when I tried to verify the same com dll with a sample console application. This is again using the .net framework 4.7.1 with the target platform as Any CPU. Also, It is working fine with both target platforms Any CPU or x86.

Can you please help if I am missing something here?

asp.net
.net
com
asked on Stack Overflow May 6, 2020 by Raghunath Machineni • edited May 6, 2020 by Abhishek Duppati

0 Answers

Nobody has answered this question yet.


User contributions licensed under CC BY-SA 3.0