'flutter run' on android command stuck at : [Waiting for observatory port ...]

0

So I'm struggling with compatibilities problem for 4 days now, iOS run and build works perfectly fine but the android version is struggling.

The thing is that when trying to "flutter run" on an android device with API 27,28 or 29 the compiler get stuck onto this line :

[ +307 ms] Starting: Intent { act=android.intent.action.RUN flg=0x20000000 cmp=com.corsicoin.app/.MainActivity (has extras) }
[        ] Waiting for observatory port to be available...

And i found no solution to this problem ... Maybe someone could guide me to the promise procedure to fix this ..

Here is my flutter doctor -v :

[✓] Flutter (Channel stable, v1.9.1+hotfix.6, on Mac OS X 10.15 19A602, locale en-FR)
    • Flutter version 1.9.1+hotfix.6 at /Users/axel/flutter
    • Framework revision 68587a0916 (6 weeks ago), 2019-09-13 19:46:58 -0700
    • Engine revision b863200c37
    • Dart version 2.5.0


[✓] Android toolchain - develop for Android devices (Android SDK version 29.0.2)
    • Android SDK at /Users/axel/Library/Android/sdk
    • Android NDK location not configured (optional; useful for native profiling support)
    • Platform android-29, build-tools 29.0.2
    • Java binary at: /Applications/Android Studio.app/Contents/jre/jdk/Contents/Home/bin/java
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1343-b01)
    • All Android licenses accepted.

[✓] Xcode - develop for iOS and macOS (Xcode 11.1)
    • Xcode at /Applications/Xcode.app/Contents/Developer
    • Xcode 11.1, Build version 11A1027
    • CocoaPods version 1.8.4

[✓] Android Studio (version 3.4)
    • Android Studio at /Applications/Android Studio.app/Contents
    • Flutter plugin version 39.0.1
    • Dart plugin version 183.6270
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1343-b01)

[✓] VS Code (version 1.39.2)
    • VS Code at /Applications/Visual Studio Code.app/Contents
    • Flutter extension version 3.5.1

[✓] Connected device (1 available)
    • Android SDK built for x86 • emulator-5554 • android-x86 • Android 9 (API 28) (emulator)

• No issues found!

Here is my flutter run -v :

[  +27 ms] executing: [/Users/axel/flutter/] git log -n 1 --pretty=format:%H
[  +42 ms] Exit code 0 from: git log -n 1 --pretty=format:%H
[        ] 68587a0916366e9512a78df22c44163d041dd5f3
[        ] executing: [/Users/axel/flutter/] git describe --match v*.*.* --first-parent --long --tags
[  +15 ms] Exit code 0 from: git describe --match v*.*.* --first-parent --long --tags
[        ] v1.9.1+hotfix.6-0-g68587a091
[   +8 ms] executing: [/Users/axel/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[  +10 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] origin/stable
[        ] executing: [/Users/axel/flutter/] git ls-remote --get-url origin
[  +11 ms] Exit code 0 from: git ls-remote --get-url origin
[        ] https://github.com/flutter/flutter.git
[  +58 ms] executing: [/Users/axel/flutter/] git rev-parse --abbrev-ref HEAD
[  +16 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] stable
[+1051 ms] executing: /Users/axel/Library/Android/sdk/platform-tools/adb devices -l
[  +12 ms] Exit code 0 from: /Users/axel/Library/Android/sdk/platform-tools/adb devices -l
[        ] List of devices attached
           emulator-5554          device product:sdk_gphone_x86 model:Android_SDK_built_for_x86 device:generic_x86 transport_id:2
[  +18 ms] executing: /Users/axel/flutter/bin/cache/artifacts/libimobiledevice/idevice_id -h
[  +57 ms] /usr/bin/xcrun simctl list --json devices
[ +145 ms] /Users/axel/Library/Android/sdk/platform-tools/adb -s emulator-5554 shell getprop
[  +47 ms] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[   +3 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[   +1 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[  +37 ms] Found plugin contacts_service at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/contacts_service-0.2.9/
[  +11 ms] Found plugin firebase_core at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/firebase_core-0.4.0+9/
[   +3 ms] Found plugin firebase_messaging at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/firebase_messaging-5.1.6/
[   +5 ms] Found plugin flutter_crashlytics at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_crashlytics-1.0.0/
[   +1 ms] Found plugin flutter_email_sender at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_email_sender-2.0.3/
[  +10 ms] Found plugin flutter_secure_storage at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_secure_storage-3.2.1+1/
[  +11 ms] Found plugin flutter_worldpay at /Users/axel/Documents/CSC/flutter_worldpay/
[   +3 ms] Found plugin geolocator at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/geolocator-5.1.1+1/
[   +2 ms] Found plugin google_api_availability at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/google_api_availability-2.0.1/
[   +1 ms] Found plugin google_maps_flutter at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/google_maps_flutter-0.5.20+1/
[   +4 ms] Found plugin image_picker at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/image_picker-0.6.1+8/
[   +2 ms] Found plugin keyboard_visibility at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/keyboard_visibility-0.5.6/
[   +3 ms] Found plugin local_auth at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/local_auth-0.6.0+1/
[   +1 ms] Found plugin location_permissions at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/location_permissions-2.0.2/
[   +4 ms] Found plugin native_device_orientation at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/native_device_orientation-0.1.2/
[   +4 ms] Found plugin path_provider at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider-0.5.0+1/
[   +1 ms] Found plugin permission_handler at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/permission_handler-3.2.1+1/
[   +7 ms] Found plugin qr_mobile_vision at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/qr_mobile_vision-0.2.2/
[   +6 ms] Found plugin share_extend at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/share_extend-1.0.9/
[   +2 ms] Found plugin shared_preferences at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences-0.5.3+4/
[   +3 ms] Found plugin sqflite at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/sqflite-1.1.6+3/
[   +8 ms] Found plugin url_launcher at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/url_launcher-5.1.2/
[  +29 ms] Found plugin contacts_service at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/contacts_service-0.2.9/
[   +8 ms] Found plugin firebase_core at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/firebase_core-0.4.0+9/
[        ] Found plugin firebase_messaging at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/firebase_messaging-5.1.6/
[   +3 ms] Found plugin flutter_crashlytics at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_crashlytics-1.0.0/
[   +1 ms] Found plugin flutter_email_sender at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_email_sender-2.0.3/
[   +3 ms] Found plugin flutter_secure_storage at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/flutter_secure_storage-3.2.1+1/
[   +7 ms] Found plugin flutter_worldpay at /Users/axel/Documents/CSC/flutter_worldpay/
[        ] Found plugin geolocator at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/geolocator-5.1.1+1/
[        ] Found plugin google_api_availability at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/google_api_availability-2.0.1/
[        ] Found plugin google_maps_flutter at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/google_maps_flutter-0.5.20+1/
[   +1 ms] Found plugin image_picker at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/image_picker-0.6.1+8/
[   +1 ms] Found plugin keyboard_visibility at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/keyboard_visibility-0.5.6/
[   +1 ms] Found plugin local_auth at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/local_auth-0.6.0+1/
[        ] Found plugin location_permissions at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/location_permissions-2.0.2/
[   +2 ms] Found plugin native_device_orientation at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/native_device_orientation-0.1.2/
[   +3 ms] Found plugin path_provider at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/path_provider-0.5.0+1/
[   +2 ms] Found plugin permission_handler at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/permission_handler-3.2.1+1/
[   +1 ms] Found plugin qr_mobile_vision at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/qr_mobile_vision-0.2.2/
[   +2 ms] Found plugin share_extend at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/share_extend-1.0.9/
[        ] Found plugin shared_preferences at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/shared_preferences-0.5.3+4/
[   +1 ms] Found plugin sqflite at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/sqflite-1.1.6+3/
[   +6 ms] Found plugin url_launcher at /Users/axel/flutter/.pub-cache/hosted/pub.dartlang.org/url_launcher-5.1.2/
[  +43 ms] ro.hardware = ranchu
[  +11 ms] executing: [/Users/axel/Documents/CSC/flutter-app/ios/Runner.xcodeproj/] /usr/bin/xcodebuild -project /Users/axel/Documents/CSC/flutter-app/ios/Runner.xcodeproj -target Runner -showBuildSettings
[+3169 ms] Exit code 0 from: /usr/bin/xcodebuild -project /Users/axel/Documents/CSC/flutter-app/ios/Runner.xcodeproj -target Runner -showBuildSettings

                                                .
                                                .
                                                .
                                                .

[  +55 ms] Using hardware rendering with device Android SDK built for x86. If you get graphics artifacts, consider enabling software rendering with "--enable-software-rendering".
[  +25 ms] Launching lib/main.dart on Android SDK built for x86 in debug mode...
[  +12 ms] Initializing gradle...
[   +6 ms] Using gradle from /Users/axel/Documents/CSC/flutter-app/android/gradlew.
[ +327 ms] executing: /usr/bin/plutil -convert json -o - /Applications/Android Studio.app/Contents/Info.plist
[  +18 ms] Exit code 0 from: /usr/bin/plutil -convert json -o - /Applications/Android Studio.app/Contents/Info.plist
[        ] {"CFBundleName":"Android Studio","JVMOptions":{"ClassPath":"$APP_PACKAGE\/Contents\/lib\/bootstrap.jar:$APP_PACKAGE\/Contents\/lib\/extensions.jar:$APP_PACKAGE\/Contents\/lib\/util.jar:$APP_PACKAGE\/Contents\/lib\/jdom.jar:$APP_PACKAGE\/Contents\/lib\/log4j.jar:$APP_PACKAGE\/Contents\/lib\/trove4j.jar:$APP_PACKAGE\/Contents\/lib\/jna.jar","JVMVersion":"1.8*,1.8+","WorkingDirectory":"$APP_PACKAGE\/Contents\/bin","MainClass":"com.intellij.idea.Main","Properties":{"idea.java.redist":"Bundled","idea.paths.selector":"AndroidStudio3.4","idea.executable":"studio","idea.platform.prefix":"AndroidStudio","idea.home.path":"$APP_PACKAGE\/Contents"}},"LSArchitecturePriority":["x86_64"],"CFBundleVersion":"AI-183.6156.11.34.5692245","CFBundleDevelopmentRegion":"English","CFBundleDocumentTypes":[{"CFBundleTypeName":"Android Studio Project File","CFBundleTypeExtensions":["ipr"],"CFBundleTypeRole":"Editor","CFBundleTypeIconFile":"studio.icns"},{"CFBundleTypeName":"All documents","CFBundleTypeExtensions":["*"],"CFBundleTypeOSTypes":["****"],"CFBundleTypeRole":"Editor","LSTypeIsPackage":false}],"NSSupportsAutomaticGraphicsSwitching":true,"CFBundlePackageType":"APPL","CFBundleIconFile":"studio.icns","NSHighResolutionCapable":true,"CFBundleShortVersionString":"3.4","CFBundleInfoDictionaryVersion":"6.0","CFBundleExecutable":"studio","LSRequiresNativeExecution":"YES","CFBundleURLTypes":[{"CFBundleTypeRole":"Editor","CFBundleURLName":"Stacktrace","CFBundleURLSchemes":["idea"]}],"CFBundleIdentifier":"com.google.android.studio","LSApplicationCategoryType":"public.app-category.developer-tools","CFBundleSignature":"????","LSMinimumSystemVersion":"10.8","CFBundleGetInfoString":"Android Studio 3.4, build AI-183.6156.11.34.5692245. Copyright JetBrains s.r.o., (c) 2000-2019"}
[ +136 ms] executing: /Users/axel/Documents/CSC/flutter-app/android/gradlew -v
[ +613 ms] 
           ------------------------------------------------------------
           Gradle 5.4.1
           ------------------------------------------------------------

           Build time:   2019-04-26 08:14:42 UTC
           Revision:     261d171646b36a6a28d5a19a69676cd098a4c19d

           Kotlin:       1.3.21
           Groovy:       2.5.4
           Ant:          Apache Ant(TM) version 1.9.13 compiled on July 10 2018
           JVM:          1.8.0_152-release (JetBrains s.r.o 25.152-b01)
           OS:           Mac OS X 10.15 x86_64
[  +17 ms] Initializing gradle... (completed in 1.1s)
[   +4 ms] Resolving dependencies...
[        ] executing: [/Users/axel/Documents/CSC/flutter-app/android/] /Users/axel/Documents/CSC/flutter-app/android/gradlew app:properties
[+2444 ms] 


                                                .
                                                .
                                                .
                                                .

[        ] 562 actionable tasks: 517 executed, 45 up-to-date
[ +356 ms] Running Gradle task 'assembleDebug'... (completed in 85.3s)
[  +50 ms] calculateSha: LocalDirectory: '/Users/axel/Documents/CSC/flutter-app/build/app/outputs/apk'/app.apk
[ +146 ms] calculateSha: reading file took 145us
[+1691 ms] calculateSha: computing sha took 1688us
[  +15 ms] Built build/app/outputs/apk/debug/app-debug.apk.
[   +8 ms] executing: /Users/axel/Library/Android/sdk/build-tools/29.0.2/aapt dump xmltree /Users/axel/Documents/CSC/flutter-app/build/app/outputs/apk/app.apk AndroidManifest.xml
[  +25 ms] Exit code 0 from: /Users/axel/Library/Android/sdk/build-tools/29.0.2/aapt dump xmltree /Users/axel/Documents/CSC/flutter-app/build/app/outputs/apk/app.apk AndroidManifest.xml
[        ] N: android=http://schemas.android.com/apk/res/android
             E: manifest (line=2)
               A: android:versionCode(0x0101021b)=(type 0x10)0x2c
               A: android:versionName(0x0101021c)="0.1.43" (Raw: "0.1.43")
               A: android:compileSdkVersion(0x01010572)=(type 0x10)0x1c
               A: android:compileSdkVersionCodename(0x01010573)="9" (Raw: "9")
               A: package="com.corsicoin.app" (Raw: "com.corsicoin.app")
               A: platformBuildVersionCode=(type 0x10)0x2c
               A: platformBuildVersionName="0.1.43" (Raw: "0.1.43")
               E: uses-sdk (line=7)
                 A: android:minSdkVersion(0x0101020c)=(type 0x10)0x15
                 A: android:targetSdkVersion(0x01010270)=(type 0x10)0x1c
               E: uses-permission (line=14)
                 A: android:name(0x01010003)="android.permission.INTERNET" (Raw: "android.permission.INTERNET")
               E: uses-permission (line=15)
                 A: android:name(0x01010003)="android.permission.USE_FINGERPRINT" (Raw: "android.permission.USE_FINGERPRINT")
               E: uses-permission (line=16)
                 A: android:name(0x01010003)="android.permission.ACCESS_FINE_LOCATION" (Raw: "android.permission.ACCESS_FINE_LOCATION")
               E: uses-permission (line=17)
                 A: android:name(0x01010003)="android.permission.READ_CONTACTS" (Raw: "android.permission.READ_CONTACTS")
               E: uses-permission (line=18)
                 A: android:name(0x01010003)="android.permission.WRITE_CONTACTS" (Raw: "android.permission.WRITE_CONTACTS")
               E: uses-permission (line=19)
                 A: android:name(0x01010003)="android.permission.WRITE_EXTERNAL_STORAGE" (Raw: "android.permission.WRITE_EXTERNAL_STORAGE")
               E: uses-permission (line=20)
                 A: android:name(0x01010003)="android.permission.USE_BIOMETRIC" (Raw: "android.permission.USE_BIOMETRIC")
               E: uses-permission (line=21)
                 A: android:name(0x01010003)="android.permission.CAMERA" (Raw: "android.permission.CAMERA")
               E: uses-feature (line=23)
                 A: android:name(0x01010003)="android.hardware.camera.autofocus" (Raw: "android.hardware.camera.autofocus")
                 A: android:required(0x0101028e)=(type 0x12)0xffffffff
               E: uses-permission (line=27)
                 A: android:name(0x01010003)="android.permission.READ_EXTERNAL_STORAGE" (Raw: "android.permission.READ_EXTERNAL_STORAGE")
               E: uses-permission (line=28)
                 A: android:name(0x01010003)="android.permission.ACCESS_NETWORK_STATE" (Raw: "android.permission.ACCESS_NETWORK_STATE")
               E: uses-permission (line=29)
                 A: android:name(0x01010003)="android.permission.WAKE_LOCK" (Raw: "android.permission.WAKE_LOCK")
               E: uses-permission (line=30)
                 A: android:name(0x01010003)="com.google.android.finsky.permission.BIND_GET_INSTALL_REFERRER_SERVICE" (Raw: "com.google.android.finsky.permission.BIND_GET_INSTALL_REFERRER_SERVICE")
               E: uses-feature (line=32)
                 A: android:glEsVersion(0x01010281)=(type 0x11)0x20000
                 A: android:required(0x0101028e)=(type 0x12)0xffffffff
               E: uses-permission (line=35)
                 A: android:name(0x01010003)="com.google.android.c2dm.permission.RECEIVE" (Raw: "com.google.android.c2dm.permission.RECEIVE")
               E: application (line=37)
                 A: android:label(0x01010001)="Corsicoin" (Raw: "Corsicoin")
                 A: android:icon(0x01010002)=@0x7f0c0000
                 A: android:name(0x01010003)="io.flutter.app.FlutterApplication" (Raw: "io.flutter.app.FlutterApplication")
                 A: android:debuggable(0x0101000f)=(type 0x12)0xffffffff
                 A: android:allowBackup(0x01010280)=(type 0x12)0x0
                 A: android:appComponentFactory(0x0101057a)="androidx.core.app.CoreComponentFactory" (Raw: "androidx.core.app.CoreComponentFactory")
                 C: " android:usesCleartextTraffic=\"true\" "
                 E: activity (line=45)
                   A: android:theme(0x01010000)=@0x7f0e00a6
                   A: android:name(0x01010003)="com.corsicoin.app.MainActivity" (Raw: "com.corsicoin.app.MainActivity")
                   A: android:launchMode(0x0101001d)=(type 0x10)0x1
                   A: android:configChanges(0x0101001f)=(type 0x11)0x400037b4
                   A: android:windowSoftInputMode(0x0101022b)=(type 0x11)0x10
                   A: android:hardwareAccelerated(0x010102d3)=(type 0x12)0xffffffff
                   E: meta-data (line=59)
                     A: android:name(0x01010003)="io.flutter.app.android.SplashScreenUntilFirstFrame" (Raw: "io.flutter.app.android.SplashScreenUntilFirstFrame")
                     A: android:value(0x01010024)=(type 0x12)0xffffffff
                   E: intent-filter (line=63)
                     E: action (line=64)
                       A: android:name(0x01010003)="android.intent.action.MAIN" (Raw: "android.intent.action.MAIN")
                     E: category (line=66)
                       A: android:name(0x01010003)="android.intent.category.LAUNCHER" (Raw: "android.intent.category.LAUNCHER")
                 E: meta-data (line=70)
                   A: android:name(0x01010003)="com.google.android.geo.API_KEY" (Raw: "com.google.android.geo.API_KEY")
                   A: android:value(0x01010024)="AIzaSyBjzbDa8CicKY9m4YkfecHUrCXtIcaFahQ" (Raw: "AIzaSyBjzbDa8CicKY9m4YkfecHUrCXtIcaFahQ")
                 E: uses-library (line=74)
                   A: android:name(0x01010003)="org.apache.http.legacy" (Raw: "org.apache.http.legacy")
                   A: android:required(0x0101028e)=(type 0x12)0x0
                 E: provider (line=78)
                   A: android:name(0x01010003)="com.sidlatau.flutteremailsender.FlutterEmailSenderFileProvider" (Raw: "com.sidlatau.flutteremailsender.FlutterEmailSenderFileProvider")
                   A: android:exported(0x01010010)=(type 0x12)0x0
                   A: android:authorities(0x01010018)="com.corsicoin.app.file_provider" (Raw: "com.corsicoin.app.file_provider")
                   A: android:grantUriPermissions(0x0101001b)=(type 0x12)0xffffffff
                   E: meta-data (line=83)
                     A: android:name(0x01010003)="android.support.FILE_PROVIDER_PATHS" (Raw: "android.support.FILE_PROVIDER_PATHS")
                     A: android:resource(0x01010025)=@0x7f100003
                 E: activity (line=88)
                   A: android:theme(0x01010000)=@0x7f0e00a5
                   A: android:name(0x01010003)="androidx.biometric.DeviceCredentialHandlerActivity" (Raw: "androidx.biometric.DeviceCredentialHandlerActivity")
                 E: service (line=92)
                   A: android:name(0x01010003)="com.google.firebase.components.ComponentDiscoveryService" (Raw: "com.google.firebase.components.ComponentDiscoveryService")
                   A: android:exported(0x01010010)=(type 0x12)0x0
                   E: meta-data (line=95)
                     A: android:name(0x01010003)="com.google.firebase.components:io.flutter.plugins.firebase.core.FlutterFirebaseAppRegistrar" (Raw: "com.google.firebase.components:io.flutter.plugins.firebase.core.FlutterFirebaseAppRegistrar")
                     A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar")
                   E: meta-data (line=98)
                     A: android:name(0x01010003)="com.google.firebase.components:io.flutter.plugins.firebasemessaging.FlutterFirebaseAppRegistrar" (Raw: "com.google.firebase.components:io.flutter.plugins.firebasemessaging.FlutterFirebaseAppRegistrar")
                     A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar")
                   E: meta-data (line=101)
                     A: android:name(0x01010003)="com.google.firebase.components:com.google.firebase.analytics.connector.internal.AnalyticsConnectorRegistrar" (Raw: "com.google.firebase.components:com.google.firebase.analytics.connector.internal.AnalyticsConnectorRegistrar")
                     A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar")
                   E: meta-data (line=104)
                     A: android:name(0x01010003)="com.google.firebase.components:com.google.firebase.iid.Registrar" (Raw: "com.google.firebase.components:com.google.firebase.iid.Registrar")
                     A: android:value(0x01010024)="com.google.firebase.components.ComponentRegistrar" (Raw: "com.google.firebase.components.ComponentRegistrar")
                 E: service (line=108)
                   A: android:name(0x01010003)="io.flutter.plugins.firebasemessaging.FlutterFirebaseMessagingService" (Raw: "io.flutter.plugins.firebasemessaging.FlutterFirebaseMessagingService")
                   E: intent-filter (line=109)
                     E: action (line=110)
                       A: android:name(0x01010003)="com.google.firebase.MESSAGING_EVENT" (Raw: "com.google.firebase.MESSAGING_EVENT")
                 E: service (line=117)
                   A: android:name(0x01010003)="com.google.firebase.messaging.FirebaseMessagingService" (Raw: "com.google.firebase.messaging.FirebaseMessagingService")
                   A: android:exported(0x01010010)=(type 0x12)0x0
                   E: intent-filter (line=120)
                     A: android:priority(0x0101001c)=(type 0x10)0xfffffe0c
                     E: action (line=121)
                       A: android:name(0x01010003)="com.google.firebase.MESSAGING_EVENT" (Raw: "com.google.firebase.MESSAGING_EVENT")
                 E: activity (line=125)
                   A: android:name(0x01010003)="com.kiwi.fluttercrashlytics.CrashActivity" (Raw: "com.kiwi.fluttercrashlytics.CrashActivity")
                 E: meta-data (line=127)
                   A: android:name(0x01010003)="firebase_crashlytics_collection_enabled" (Raw: "firebase_crashlytics_collection_enabled")
                   A: android:value(0x01010024)=(type 0x12)0x0
                 E: provider (line=131)
                   A: android:name(0x01010003)="com.crashlytics.android.CrashlyticsInitProvider" (Raw: "com.crashlytics.android.CrashlyticsInitProvider")
                   A: android:exported(0x01010010)=(type 0x12)0x0
                   A: android:authorities(0x01010018)="com.corsicoin.app.crashlyticsinitprovider" (Raw: "com.corsicoin.app.crashlyticsinitprovider")
                   A: android:initOrder(0x0101001a)=(type 0x10)0x5a
                 E: provider (line=136)
                   A: android:name(0x01010003)="com.zt.shareextend.ShareExtendProvider" (Raw: "com.zt.shareextend.ShareExtendProvider")
                   A: android:exported(0x01010010)=(type 0x12)0x0
                   A: android:authorities(0x01010018)="com.corsicoin.app.shareextend.fileprovider" (Raw: "com.corsicoin.app.shareextend.fileprovider")
                   A: android:grantUriPermissions(0x0101001b)=(type 0x12)0xffffffff
                   E: meta-data (line=141)
                     A: android:name(0x01010003)="android.support.FILE_PROVIDER_PATHS" (Raw: "android.support.FILE_PROVIDER_PATHS")
                     A: android:resource(0x01010025)=@0x7f100002
                 E: meta-data (line=146)
                   A: android:name(0x01010003)="com.google.android.gms.vision.DEPENDENCIES" (Raw: "com.google.android.gms.vision.DEPENDENCIES")
                   A: android:value(0x01010024)="barcode" (Raw: "barcode")
[   +8 ms] Stopping app 'app.apk' on Android SDK built for x86.
[        ] executing: /Users/axel/Library/Android/sdk/platform-tools/adb -s emulator-5554 shell am force-stop com.corsicoin.app
[  +42 ms] executing: /Users/axel/Library/Android/sdk/platform-tools/adb -s emulator-5554 shell pm list packages com.corsicoin.app
[  +58 ms] package:com.corsicoin.app
[   +3 ms] executing: /Users/axel/Library/Android/sdk/platform-tools/adb -s emulator-5554 shell cat /data/local/tmp/sky.com.corsicoin.app.sha1
[  +28 ms] f80e9458fae2d71a385629ef7c98c7aa85b4218f
[        ] Installing APK.
[   +2 ms] executing: /Users/axel/Library/Android/sdk/platform-tools/adb version
[  +21 ms] Android Debug Bridge version 1.0.41
           Version 29.0.4-5871666
           Installed as /Users/axel/Library/Android/sdk/platform-tools/adb
[   +1 ms] executing: /Users/axel/Library/Android/sdk/platform-tools/adb start-server
[  +12 ms] Installing build/app/outputs/apk/app.apk...
[        ] executing: /Users/axel/Library/Android/sdk/platform-tools/adb -s emulator-5554 install -t -r /Users/axel/Documents/CSC/flutter-app/build/app/outputs/apk/app.apk
[+4894 ms] Performing Streamed Install
           Success
[        ] Installing build/app/outputs/apk/app.apk... (completed in 4.9s)
[   +2 ms] executing: /Users/axel/Library/Android/sdk/platform-tools/adb -s emulator-5554 shell echo -n 34ac41d7e348b336d6a17368357065d2d4254dbc > /data/local/tmp/sky.com.corsicoin.app.sha1
[  +53 ms] Android SDK built for x86 startApp
[   +2 ms] executing: /Users/axel/Library/Android/sdk/platform-tools/adb -s emulator-5554 shell am start -a android.intent.action.RUN -f 0x20000000 --ez enable-background-compilation true --ez enable-dart-profiling true --ez enable-checked-mode true --ez verify-entry-points true com.corsicoin.app/com.corsicoin.app.MainActivity
[ +123 ms] Starting: Intent { act=android.intent.action.RUN flg=0x20000000 cmp=com.corsicoin.app/.MainActivity (has extras) }
[        ] Waiting for observatory port to be available...
android
flutter
dart
asked on Stack Overflow Oct 25, 2019 by Axel Frau

0 Answers

Nobody has answered this question yet.


User contributions licensed under CC BY-SA 3.0