Deployment on local machine - HTTP Error 500.19 - Internal Server Error 0x8007000d

0

I am trying to deploy an asp.net core web app to my local machine but it gives me the following error: HTTP Error 500.19 - Internal Server Error 0x8007000d. It is the first time I'm attempting it, so I don't understand what is the problem. Searching for solutions, I have found out that there is malformed xml element in the web.config file but since I have never done it, I couldn't understand how to fix this.

This is my web.config file:

<?xml version="1.0" encoding="utf-8"?>
   <configuration>
    <location path="." inheritInChildApplications="false">
       <system.webServer>
          <handlers>
               <add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModule" resourceType="Unspecified" />
          </handlers>
          <aspNetCore processPath="dotnet" arguments=".\MyApp.dll" stdoutLogEnabled="false" stdoutLogFile=".\logs\stdout" />
      </system.webServer>
     </location>
   </configuration>
  <!--ProjectGuid: 110a64bf-38d2-4b16-8536-814161f00f23-->

What am I doing wrong?

asp.net-mvc
web-deployment
asked on Stack Overflow Jan 11, 2019 by NoWayHandshake • edited Jan 11, 2019 by NoWayHandshake

1 Answer

0

It was giving a problem because it is a asp.net core app. I followed the instructions in these links: https://stackify.com/how-to-deploy-asp-net-core-to-iis/ https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/iis/?view=aspnetcore-2.2

answered on Stack Overflow Jan 15, 2019 by NoWayHandshake

User contributions licensed under CC BY-SA 3.0