Zkemkeeper.dll not working after deploying, Class not registered?

0

I am trying to integrate to ZKTeco bio-metric device with my web application. It's working absolutely fine but when I deploy application and try to connect with bio-metric device I get the following error:

Retrieving the COM class factory for component with CLSID {00853A19-BD51-419B-9269-2DABE57EB61F} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

I am following this tutorial.

I tried following solutions:

  1. I changed the reference of my dll to copy to local.
  2. I changed the targeted CPU before deploying.

But both the solutions didn't work. What could be possible solution?

c#
visual-studio
deployment
zkteco
asked on Stack Overflow Nov 13, 2018 by Ashir K.

1 Answer

2

You must register zkemkeeper in every computer that will use your program, not just in the development environment.

To register the zkemkeeper dll in both development and deployment computers, follow the steps provided in the solution of this post: Error when inserting finger print data into database table. When registering in deployment computers, avoid the steps related with the Visual Studio.

You should also take a look to this document, it provides useful information to understand how zkemkeeper works: COM Class Objects and CLSIDs.

Best regards.

answered on Stack Overflow Nov 14, 2018 by Roberto Vázquez

User contributions licensed under CC BY-SA 3.0