VBoxManage: error: Failed to create the host-only adapter (II)

4

This error has previously been reported in post: VBoxManage: error: Failed to create the host-only adapter and it keeps reoccurring for new versions of Windows/vagrant/OracleVB as described below. If anyone has identified a solution to this problem for the setup that is described below, please share here:

  • host: Windows 10 Home version 1607 ; OS build 14939.105
  • guest: using the "bento/ubuntu-14.04" image
  • Vagrant: 1.8.5
  • Oracle VB: 5.1.4 r110228 (Qt5.5.1)

I installed Oracle VB and then Vagrant (both fresh installs) and then ran vagrant up as usuas in one of my workspaces. After vagrant had finished downloading the virtual box, it gave the following error output when attempting to start the VM:

C:\Users\AHL\workspace>vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Box 'bento/ubuntu-14.04' could not be found. Attempting to find and install...
    default: Box Provider: virtualbox
    default: Box Version: >= 0
==> default: Loading metadata for box 'bento/ubuntu-14.04'
    default: URL: https://atlas.hashicorp.com/bento/ubuntu-14.04
==> default: Adding box 'bento/ubuntu-14.04' (v2.2.9) for provider: virtualbox
    default: Downloading: https://atlas.hashicorp.com/bento/boxes/ubuntu-14.04/versions/2.2.9/providers/virtualbox.box
    default: Progress: 100% (Rate: 74436/s, Estimated time remaining: --:--:--)
==> default: Successfully added box 'bento/ubuntu-14.04' (v2.2.9) for 'virtualbox'!
==> default: Importing base box 'bento/ubuntu-14.04'...
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'bento/ubuntu-14.04' is up to date...
==> default: Setting the name of the VM: workspace_default_1473571560144_68182
==> default: Clearing any previously set network interfaces...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["hostonlyif", "create"]

Stderr: 0%...
Progress state: E_FAIL
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Operation canceled by the user
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component VirtualBoxWrap, interface IVirtualBox
VBoxManage.exe: error: Context: "enum RTEXITCODE __cdecl handleCreate(struct HandlerArg *)" at line 71 of file VBoxManageHostonly.cpp

C:\Users\AHL\workspace>

Vagrantfile:

Vagrant.configure(2) do |config|
  config.vm.box = "bento/ubuntu-14.04"
  config.vm.network "private_network", ip: "192.168.33.10"
end
vagrant
virtualbox
vagrant-windows
asked on Stack Overflow Sep 11, 2016 by AHL • edited May 23, 2017 by Community

3 Answers

1

The solution to this problem appears to be the same as reported in the related post:

Although the VM in the Oracle VB GUI appears as not running, you must manually start it through Oracle VB GUI (this should work and allow you to login to the box) and then manually power it off again (also through Oracle VB GUI). Then, run vagrant up again and it should work.

If you're having issues with this setup then please add comments to this post.

answered on Stack Overflow Sep 11, 2016 by AHL
1

Try to execute

C:\HashiCorp\Vagrant\bin\vagrant.exe as administrator and then

vagrant up in command line.

It worked for me.

answered on Stack Overflow May 10, 2017 by Thavia Farias
-1

UPDATE 2020.10: Steps below not work anymore.

If you installed VirtualBox without Network support or if you don't has Network support installed.

Try:

  1. open VirtualBox
  2. Menu File ---> Settings ---> Network
  3. On the right side, click button "add new network" Image
  4. Assume the default settings
  5. At Terminal type: vagrant up

For me, it worked. Good luck there!

answered on Stack Overflow Apr 4, 2019 by Carlos Thadeu • edited Oct 7, 2020 by Carlos Thadeu

User contributions licensed under CC BY-SA 3.0