Windows 10 SDK won't install to Visual Studio

6

I've been trying to get Visual Studio and the Windows 10 SDK to work for over a week now. First I couldn't install Visual Studio. That problem was resolved by uninstalling EVERYTHING vaguely related to VS2015, thanks to manually going through everything, but also the Visual Studio "TotalUninstaller".

Plot twist: Now that I've managed to get VS2015 installed and running, I can't get the SDK to install. I've selected it with the installation process, tried to modify VS after, tried to install it with the Standalone installer, but none of it works. Every time, the installer doesn't notice anything wrong, all the tools appear in the start menu, a new "Program Files (x86)/WindowsKits/10.0" folder appears, with all the correct files, but VS can't open any UWP projects, can't create new any, and the SDK doesn't appear in the Extensions list.

When I uninstalled everything, there was only one thing I couldn't get rid of: "Windows 10 for Mobile Image - 10.0.10240.0". It just opens, runs for a second, and closes, achieving nothing in the process. As I couldn't get rid of this, I manually deleted any "Windows Kits" related folder in Program Files, Program Files (x86), ProgramData, and anything in the AppData folder. But this piece of fluffy garbage didn't leave my installed programs list. Could this have something to do with not being able to install the Windows 10 SDK correctly?

I looked in the install logs, and this is the only error I saw:

[371C:398C][2016-08-08T21:13:35]i301: Applying execute package: {7a68448b-9cf2-4049-bd73-5875f1aa7ba2}, action: Install, path: C:\ProgramData\Package Cache\{7a68448b-9cf2-4049-bd73-5875f1aa7ba2}\vsupdate_KB3022398.exe, arguments: '"C:\ProgramData\Package Cache\{7a68448b-9cf2-4049-bd73-5875f1aa7ba2}\vsupdate_KB3022398.exe" -quiet -burn.related.patch -burn.ignoredependencies={248fcd1e-5ee1-421d-893f-ec0a94dd7b01} -burn.ancestors={248fcd1e-5ee1-421d-893f-ec0a94dd7b01}'
[371C:398C][2016-08-08T21:13:35]e000: Error 0x80070003: Failed to create embedded process atpath: C:\ProgramData\Package Cache\{7a68448b-9cf2-4049-bd73-5875f1aa7ba2}\vsupdate_KB3022398.exe
[371C:398C][2016-08-08T21:13:35]e000: Error 0x80070003: Failed to run embedded bundle.
[371C:398C][2016-08-08T21:13:35]e000: Error 0x80070003: Failed to run bundle as embedded from path: C:\ProgramData\Package Cache\{7a68448b-9cf2-4049-bd73-5875f1aa7ba2}\vsupdate_KB3022398.exe
[371C:398C][2016-08-08T21:13:35]e000: Error 0x80070003: Failed to execute EXE package.
[287C:137C][2016-08-08T21:13:35]e000: Error 0x80070003: Failed to configure per-machine EXE package.

It appears in every log when I try to install vs2015 with the right option ticked, or when I use the standalone installer. I've looked in C:\ProgramData\Package Cache and there is no {7a68448b-9cf2-4049-bd73-5875f1aa7ba2} folder, and none of the other folders contain "vsupdate_KB3022398.exe". It looks like this is the root of the problem.

EDIT: I've created the folder that was missing and added "vsupdate_KB3022398.exe" to it (found it online, hosted on a Microsoft server), and there are no more errors left. However, the problem still isn't fixed. The SDK simply refuses to show up. I think I'm going to have to do a clean install.

visual-studio
visual-studio-2015
windows-10
uwp
asked on Stack Overflow Aug 7, 2016 by user2950509 • edited Aug 8, 2016 by user2950509

4 Answers

3

I had the issue of Windows 10 SDK 14393 failing to install on Windows 7 OS. This problem occurred when installing as part of Visual Studio 2015 and also running the Standalone Installer for the Windows 10 SDK 14393. According to the logs, the Windows Desktop Extension SDK failed to install.

As a work-around I installed Windows 10 SDK 10586 (Installed successfully) Then I installed Windows 10 SDK 14393 (Installed successfully) Both versions of the Windows 10 SDK appear as choices under Target Platform Version in Visual Studio 2015 for me.

Apparently the Windows 10 SDK 14393 installer is missing something which it requires to run successfully on Windows 7. (Something that must be present in the previous version)

answered on Stack Overflow Jan 18, 2017 by Clash
0

Sorry for the difficulty. There are 2 known issues that are causing 'Fatal Error' in the Windows SDK install.
See the Windows SDK Tools Issues Forum.

You probably have (had) a pre-release of the SDK and one of the contracts installed is causing MDMerge to fail during setup. Uninstalling the prerelease version of the SDK should avoid this issue.

Thanks, kevin

answered on Stack Overflow Aug 19, 2016 by user6736017
0

I had the MDMerge problem, after uninstalling all previous Windows 10 SDK toolkits, still couldn't install. Fixed it by moving the contents of: "C:\Program Files (x86)\Windows Kits\10", ran the installer again and it installed fine.

answered on Stack Overflow Nov 14, 2016 by Aaron Smith
0

This is what I did and it kind of worked for me. Remove everything in the linker ( PROJECT -> LINKER -> Input -> Additional Dependencies, as can be seen in this screenshot

enter image description here

answered on Stack Overflow Nov 30, 2016 by Sunil Kumar • edited Nov 30, 2016 by Bizhan

User contributions licensed under CC BY-SA 3.0