Managed Bootstrapper Application Host - Upgrade from WiX 3.8 to 3.10 error

0

I started using WiX with version 3.8 and everything works fine, including create *.msi file and Bootstrapper *.exe installation file. I can also create installation UI for my own. Now my company upgrade VS 2013 to VS 2015 and WiX 3.8 is now incompatible. Therefore, I have to upgrade WiX 3.8 to 3.10.2. And now my custom UI installer cannot work any more. I check the log file and get the following error:

[1ACC:029C][2016-07-05T12:41:03]e000: Error 0x80070003: Failed to open handle to engine process path: C:\Users\MinhHo\AppData\Local\Temp{5B7E6773-DC64-4BAD-8E5A-F2EA0EEAEC98}.cr\MyInstaller.exe

[1ACC:029C][2016-07-05T12:41:03]e000: Error 0x80070003: Failed to initialize engine section.

[1ACC:029C][2016-07-05T12:41:03]e000: Error 0x80070003: Failed to initialize engine state.

Here is my Bundle.wxs:

<?xml version="1.0" encoding="UTF-8"?>
<Wix xmlns="http://schemas.microsoft.com/wix/2006/wi"
     xmlns:bal="http://schemas.microsoft.com/wix/BalExtension"
     xmlns:util="http://schemas.microsoft.com/wix/UtilExtension"
     xmlns:netf="http://schemas.microsoft.com/wix/NetFxExtension">

  <Bundle Name="MyInstaller version !(bind.packageVersion.MySetup)" 
          Version="1.0.0.0" 
          Manufacturer="My Company" 
          UpgradeCode="C97000F4-8A9A-4FCA-9F2A-67E39B136BE8"
          DisableRemove="yes" DisableModify="yes">
    <BootstrapperApplicationRef Id="ManagedBootstrapperApplicationHost">
      <Payload SourceFile="..\BA_UI\BootstrapperCore.config"/>
      <Payload SourceFile="..\BA_UI\bin\x86\Compile\TestBA.dll"/>
      <Payload SourceFile="..\BA_UI\bin\x86\Compile\TestBA.pdb"/>
      <Payload SourceFile="..\BA_UI\bin\x86\Compile\VTRegScan.dll"/>
      <Payload SourceFile=".\Microsoft.Deployment.WindowsInstaller.dll"/>
    </BootstrapperApplicationRef>


    <Variable Name="InstallDir" Type="string" Value="&quot;[ProgramFilesFolder]MyApp\&quot;"
              bal:Overridable="yes" Hidden="yes" />

    <Chain>
      <PackageGroupRef Id="NetFx451Redist"/>

      <MsiPackage Id="MySetup" SourceFile="..\MyApp_setup\bin\Compile\MySetup.msi" Visible="yes" Cache="no">
        <MsiProperty Name="INSTALLLOCATION" Value="[InstallDir]"/>
      </MsiPackage>

      <ExePackage SourceFile=".\vcredist_x86_12.exe"
                  DownloadUrl="http://download.microsoft.com/download/2/E/6/2E61CFA4-993B-4DD4-91DA-3737CD5CD6E3/vcredist_x86.exe"
                  Id="vcredist_x86_12" Compressed="yes" Vital="no"/>
    </Chain>
  </Bundle>
</Wix>

Please tell me what I have to do to make my installer working again.

Thank you.

c#
wpf
wix
bootstrapper
applicationhost
asked on Stack Overflow Jul 5, 2016 by Minh Ho • edited Jul 5, 2016 by Minh Ho

0 Answers

Nobody has answered this question yet.


User contributions licensed under CC BY-SA 3.0