New installation of laravel 5.2. siteurl/public/index.php gives me a 500.19 "web.config" error

2

EDIT: Finally got it. Had to install URL Rewriter. Getting a new error now but looks like laravel is running at least!

IIS 7.5

PHP 5.5.33

Laravel 5.2

Error Summary:

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

Detailed Error Information

Module  IIS Web Core
Notification    BeginRequest
Handler Not yet determined
Error Code  0x8007000d
Config Error    
Config File \\?\C:\inetpub\wwwroot\laravel-profile\public\web.config**
Requested URL   http://localhost:80/laravel-profile/public/index.php
Physical Path   C:\inetpub\wwwroot\laravel-profile\public\index.php
Logon Method    Not yet determined
Logon User  Not yet determined

Config Source

   -1: 
    0: 

Haven't changed my web.config, but here it is:

<configuration>
  <system.webServer>
    <rewrite>
      <rules>
        <rule name="Imported Rule 1" stopProcessing="true">
          <match url="^(.*)/$" ignoreCase="false" />
          <conditions>
            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
          </conditions>
          <action type="Redirect" redirectType="Permanent" url="/{R:1}" />
        </rule>
        <rule name="Imported Rule 2" stopProcessing="true">
          <match url="^" ignoreCase="false" />
          <conditions>
            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
          </conditions>
          <action type="Rewrite" url="index.php" />
        </rule>
      </rules>
    </rewrite>
  </system.webServer>
</configuration>

The only thing I've changed was adding my database details.

EDIT: .config was blocked in handler mappings but I've removed that and restarted IIS and still having the same issue.

I'm not sure where to go from here. I've recently upgraded php from 5.3 (old laptop, I know), but everything else seems to be running without issue!

Thanks

php
laravel
iis
laravel-5.2
asked on Stack Overflow Apr 20, 2016 by RachFee • edited Apr 21, 2016 by Bharatesh

0 Answers

Nobody has answered this question yet.


User contributions licensed under CC BY-SA 3.0