Visual Studio Community 2015 with Update 2 Installation Failed

1

After Microsoft had released Visual Studio Update 2 I downloaded the full ISO image and then installed update successfully, but when I launched it freeze on splash screen (now I knew that issue caused by some extension, but it too late) so I tried to do clean uninstall by following steps from this thread

--> Error Installing Visual Studio 2015 Enterprise Update 1 with Team Explorer

  1. run vs_community.exe /uninstall /force
  2. delete all Visual Studio 2015 related folders
  3. delete all Visual Studio 2015 registry

After that I installed Visual Studio 2015 Community again it failed with new errors

  • Azure AD Authentication Connected Services -> Packages Failed

  • Microsoft Azure Mobile Services Connected Service -> Package Failed

Although I tried to resolve this problem by follow this thread

--> Multiple Errors Installing Visual Studio 2015 Community Edition

Unfortunately, no method work for me. I tried to reinstall many times and also tried with Visual Studio Professional with Update 2 ISO and faced the same issues.

My OS is Windows 10 Professional and this is some part of visual studio install log

[198C:29FC][2016-04-08T09:11:19]i323: Registering package dependency provider: {3FEAC561-1CF6-41D6-B0F3-BECDD9C88A1B}, version: 14.0.23107, package: AuthenticationConnectedServices_VS [2990:09CC][2016-04-08T09:11:19]i000: MUX: ExecutePackageBegin PackageId: AuthenticationConnectedServices_VS [198C:29FC][2016-04-08T09:11:19]i301: Applying execute package: AuthenticationConnectedServices_VS, action: Install, path: C:\ProgramData\Package Cache{3FEAC561-1CF6-41D6-B0F3-BECDD9C88A1B}v14.0.23107\packages\AuthenticationConnectedServices\AuthenticationConnectedServices_VisualStudio14.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" NOVSUI="1" VS7.3643236F_FC70_11D3_A536_0090278A1BB8="C:\Program Files (x86)\Microsoft Visual Studio 14.0\"' [2990:09CC][2016-04-08T09:11:23]i000: MUX: ExecuteError: Package (AuthenticationConnectedServices_VS) failed: Error Message Id: 1722 ErrorMessage: There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.
[198C:29FC][2016-04-08T09:11:23]e000: Error 0x80070643: Failed to install MSI package. [198C:29FC][2016-04-08T09:11:23]e000: Error 0x80070643: Failed to execute MSI package. [2990:09CC][2016-04-08T09:11:23]e000: Error 0x80070643: Failed to configure per-machine MSI package. [2990:09CC][2016-04-08T09:11:23]i000: MUX: Installation size in bytes for package: AuthenticationConnectedServices_VS MaxAppDrive: 0 MaxSysDrive: 2605056 AppDrive: 0 SysDrive: 0 [2990:09CC][2016-04-08T09:11:23]i000: MUX: Return Code:0x80070643 Msi Messages:There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Result Detail:0 Restart:None [2990:09CC][2016-04-08T09:11:23]i000: MUX: Set Result: Return Code=-2147023293 (0x80070643), Error Message=There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. , Result Detail=, Vital=False, Package Action=Install, Package Id=AuthenticationConnectedServices_VS [2990:09CC][2016-04-08T09:11:23]i000: Setting string variable 'BundleResult' to value '0' [2990:09CC][2016-04-08T09:11:23]w350: Applied non-vital package: AuthenticationConnectedServices_VS, encountered error: 0x80070643. Continuing... [198C:29FC][2016-04-08T09:11:23]i325: Registering dependency: {fff81b2c-ab2d-44ff-a04a-a516a29e3e81} on package provider: {3FEAC561-1CF6-41D6-B0F3-BECDD9C88A1B}, package: AuthenticationConnectedServices_VS [198C:29FC][2016-04-08T09:11:23]i323: Registering package dependency provider: {A4495E4F-5218-48FB-8AD2-F3076011B9E1}, version: 14.0.23107, package: MobileServicesConnectedServices_VS [2990:09CC][2016-04-08T09:11:23]i000: MUX: ExecutePackageBegin PackageId: MobileServicesConnectedServices_VS [198C:29FC][2016-04-08T09:11:23]i301: Applying execute package: MobileServicesConnectedServices_VS, action: Install, path: C:\ProgramData\Package Cache{A4495E4F-5218-48FB-8AD2-F3076011B9E1}v14.0.23107\packages\MobileServicesConnectedServices\MobileServicesConnectedServices_VisualStudio14.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" NOVSUI="1" VS7.3643236F_FC70_11D3_A536_0090278A1BB8="C:\Program Files (x86)\Microsoft Visual Studio 14.0\"' [2990:09CC][2016-04-08T09:11:25]i000: MUX: ExecuteError: Package (MobileServicesConnectedServices_VS) failed: Error Message Id: 1722 ErrorMessage: There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.
[198C:29FC][2016-04-08T09:11:25]e000: Error 0x80070643: Failed to install MSI package. [198C:29FC][2016-04-08T09:11:25]e000: Error 0x80070643: Failed to execute MSI package. [2990:09CC][2016-04-08T09:11:25]e000: Error 0x80070643: Failed to configure per-machine MSI package. [2990:09CC][2016-04-08T09:11:25]i000: MUX: Installation size in bytes for package: MobileServicesConnectedServices_VS MaxAppDrive: 0 MaxSysDrive: 5218304 AppDrive: 0 SysDrive: 131072 [2990:09CC][2016-04-08T09:11:25]i000: MUX: Return Code:0x80070643 Msi Messages:There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Result Detail:0 Restart:None [2990:09CC][2016-04-08T09:11:25]i000: Setting string variable 'BundleResult' to value '0' [2990:09CC][2016-04-08T09:11:25]w350: Applied non-vital package: MobileServicesConnectedServices_VS, encountered error: 0x80070643. Continuing... [198C:29FC][2016-04-08T09:11:25]i325: Registering dependency: {fff81b2c-ab2d-44ff-a04a-a516a29e3e81} on package provider: {A4495E4F-5218-48FB-8AD2-F3076011B9E1}, package: MobileServicesConnectedServices_VS

visual-studio
visual-studio-2015
asked on Stack Overflow Apr 8, 2016 by Supitch • edited May 23, 2017 by Community

1 Answer

0

I cannot speak to Windows 10, and I noticed you have linked to two of the main articles I used, but here is my answer on how I got VS 2015 CE Update 2 working on Windows 7. It includes a few minor items not noted in the other articles with may (or may not =P) have made a difference.

answered on Stack Overflow Apr 26, 2016 by Anaksunaman • edited May 23, 2017 by Community

User contributions licensed under CC BY-SA 3.0