Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED)) in visual studio

5

Am a newbie to windows 10 uwp having migrated from wpf applications. I know this question has been asked before but none has been able to solve my problem. Recently, I attempted recreating the Hamburger menu for a uwp application I am creating by following the instructions on a GitHub page https://github.com/vborovikov/hamburger .

Everything was going on well till I encountered the error "Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED)) ". After debugging, I realized the following line of code caused the error

<Setter Property="BorderBrush" Value="{x:Null}" /> 

Just to explain the project from the GitHub page; assuming you have a blank uwp xaml page, you have to add 2 files shell.xaml and shell.xaml.cs to your project as well as modifying the app.xaml. Further instructions are on the Github page. I added this but after running this I encountered the error.

I also tried the instructions from http://windows.microsoft.com/en-gb/windows-vista/windows-update-error-8000ffff but to no avail. Am quite confused with the explanation because I could not find the COMPONENTS as described on the page.

Please any suggestion will be helpful.

visual-studio-2015
win-universal-app
hamburger-menu
asked on Stack Overflow Mar 19, 2016 by Siobhan

2 Answers

1

I encountered this Error: Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED)) in Visual Studio 2017 when just changing the Solution Configuration from Debug to Release.

Fortunately, reopening Visual Studio eliminate this error.

answered on Stack Overflow Feb 21, 2020 by mr NAE
0

Seems various causes lead to this error: in Visual Studio 2019 Community Edition (Studio Version 16.5.3) I added a Windows Form to an existing project, named it including the ending .cs - did not like that at all. I was not able to save the project, neither that specific file nor the project but was confronted with the 'catastrophic error...'. Luckly copy/past to Visual studio 2017 and past into newly added, blank form (that worked smoothly!) although the same problem occurred until I added the new form without suffix .cs!

answered on Stack Overflow May 22, 2020 by Andy3D

User contributions licensed under CC BY-SA 3.0