Visual Studio 2015 Community Edition, Windows 10 and IIS


I have been having a hard time getting Visual Studio 2015 CE and IIS express to run on my windows 10 machine. Even when I make a default MVC5 web application and attempt to run it without making any changes I usually see the error below.

Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'Business, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

I have read a few posts that talk about using the netstat -ano command and finding the PID of the process using the same port, it always ends up being PID 4 aka "SYSTEM". I have tried uninstalling IIS Express and enabling the local IIS under "Windows Features" and what happens is I receive the same error, but after like 10 page refreshes the site loads.

Has anyone else come across this?
asked on Stack Overflow Oct 27, 2015 by Elliott Quick • edited Jun 20, 2020 by Community

1 Answer


I hate to say it, but the way I resolved this issue was by reverting back to Visual Studio 2013, I can't state for certain the the issue was with the 2015 Community Edition of Visual Studio, but at this time VS2013 is what works.

answered on Stack Overflow Oct 29, 2015 by Elliott Quick

User contributions licensed under CC BY-SA 3.0