Could not load file or assembly System, Version=2.0.5.0 in .NET 4 MVC 4 application

23

Been searching for ages, can't find anything helpful. Here is the exception I'm getting:

Could not load file or assembly 'System, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047) 

Exception Details: System.IO.FileLoadException: Could not load file or assembly 'System, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)

Stack Trace: 

[FileLoadException: Could not load file or assembly 'System, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)]
StructureMap.Graph.PluginGraph..ctor() in c:\BuildAgent\work\996e173a8ceccdca\src\StructureMap\Graph\PluginGraph.cs:41
StructureMap.PluginGraphBuilder..ctor() in c:\BuildAgent\work\996e173a8ceccdca\src\StructureMap\PluginGraphBuilder.cs:22
StructureMap.InitializationExpression..ctor() in c:\BuildAgent\work\996e173a8ceccdca\src\StructureMap\InitializationExpression.cs:22
StructureMap.ObjectFactory.Initialize(Action`1 action) in c:\BuildAgent\work\996e173a8ceccdca\src\StructureMap\ObjectFactory.cs:47
...

This applications works fine on the test server but is throwing this exception on the production server. As you can see, the StructureMap code is what is causing the exception.

I had to convert this app to .NET 4 from 4.5 because 4.5 wasn't installed on the production server. After the conversion, the app still works fine on my local machine and the test server.

I have already set the Copy Local to True for the System assembly, but since the referenced version is 4.0.0.0 and not 2.0.5.0, I this made no difference.

Let me know if any more info is needed. Any help you may be able to provide is appreciated.

c#
asp.net-mvc
asked on Stack Overflow May 28, 2014 by tarnold86

6 Answers

40

Make sure your .NET framework is patched. Microsoft released patches to .NET to allow Portable Class Libraries to properly find the appropriate runtime (KB2468871). If you are seeing the above exception (or something like it), it means you're missing the latest .NET framework patches.

answered on Stack Overflow Jul 1, 2014 by Ryan Kohn
1

Edit the web.config file to remove the reference, which is not required for normal operation:

1 - Open the web.config file in the root of your site

2 - Find the following line and comment it out():xxxxx-is your assembly name.

<add assembly="xxxxx", Version=2.0.5.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

3 - Save and close the web.config file and try again

answered on Stack Overflow May 28, 2014 by Jay
1

I found that it was the "await" and "async" that where giving me trouble.

I had Windows XP SP3 with only .NET 4.0, but had to update it to .NET 4.0.3 using KB2600211 - this wasn't updated automatically through Windows Update when .NET 4.0.3 came out because the computer is off-grid.

This is the link to the update:

https://www.microsoft.com/en-us/download/details.aspx?id=29053

answered on Stack Overflow Nov 10, 2017 by Rafael Ventura
0

I just want to share another solution from here that solved the problem on my development machine: installing Silverlight 5 SDK (only 11.2MB at the time of writing this post) was enough to make everything working.

answered on Stack Overflow Dec 1, 2014 by melmi
0

Install Microsoft® Silverlight® 5 SDK from the following link. It resolves and works fine for me.

SDK download

answered on Stack Overflow Sep 26, 2016 by Siby Sunny
0

Starting from a machine configuration that only had VS2017 and Silverlight 5 SDK on it, I installed VS2015 on top of that. This is when I started getting the System.Core and System.Windows problems.

When I uninstalled VS2015 and re-installed Silverlight 5 SDK, these problems went away.

answered on Stack Overflow Oct 30, 2018 by CINCHAPPS

User contributions licensed under CC BY-SA 3.0