Wix Bootstrapper setup.exe never starts and log reads Failed to load theme controls

2

Environment

Using a Bootstrapper project in Visual Studio 2012/Visual Studio 2013

Windows 7 Enterprise SP1

WixToolset 3.8

Details

Setup.exe never runs

The log file in AppData/Local/Temp/[WixBundleName][DateTime].log reads "Error 0x8007000d: Failed to load theme controls."

wix
themes
bootstrapper
burn
wix3
asked on Stack Overflow May 7, 2014 by JDennis • edited Jan 12, 2016 by Yan Sklyarenko

2 Answers

4

I have found that editing the Theme/Image[@ImageFile] value to anything other than Logo.png with cause the described error.

Changing the value back to Logo.png reverses the error.

Setting the value in Wix/Bundle/bal:WixStandardBootstrapperApplication[@LogoFile] appropriately changes the image and does not cause the setup.exe to produce an error.

Note I downloaded and used the default theme for HyperlinkLicense for my custom template with only change being the ImageFile attribute. It is improbable that this was a result of ill-formed xml.

answered on Stack Overflow May 7, 2014 by JDennis
0

In addition to JDennis' answer: If you want to change the image, you should not modify the theme file. You need to define LogoFile attribute of the bal:WixStandardBootstrapperApplication element in your bundle:

<BootstrapperApplicationRef Id="WixStandardBootstrapperApplication.HyperlinkLicense">
                  <bal:WixStandardBootstrapperApplication LicenseUrl="" LogoFile="myLogo.png" ThemeFile="myHyperlinkTheme.xml" LocalizationFile="myHyperlinkTheme.wxl" />
</BootstrapperApplicationRef>
answered on Stack Overflow Sep 30, 2019 by Mum

User contributions licensed under CC BY-SA 3.0