DNN website issues

2

We followed every steps given in installation guide in dot net nuke site for DotNetNuke_Community_07.00.02. We have database server on virtual machine and we use SQL server authentication.

1) When we click edit page in home page it redirect to home page and nothing happens. 2) When we check chrome console it shows

POST http://dnndev.me/DesktopModules/internalservices/API/controlbar/ToggleUserMode 401 (Unauthorized)

Please anybody can tell me what I am going wrong? Thank you in advance.

EDIT

Chris, we had a lot more installed, we removed it and set it exactly as you have given above but no luck. Tried reinstalling aspnet_regiis -i as well but still no luck.

It is certain that the authentication is the issue. Please note that the machine is a Windows 7 machine and is on a domain.

We have also double checked that the app pool uses the app pool identity and not LOCALSERVICE etc. We use a SQL Server on another machine and it uses the sa account at this time which is absolutely powerful.

Please see the following extract from Failed Trace. I have also dumped the trace preceding the Warning.

ModuleName ManagedPipelineHandler 
Notification 128 
HttpStatus 401 
HttpReason Unauthorized 
HttpSubStatus 0 
ErrorCode 0 
ConfigExceptionInfo  
Notification EXECUTE_REQUEST_HANDLER 
ErrorCode The operation completed successfully. (0x0) 
35.  AspNetPipelineEnter Data1="DotNetNuke.HttpModules.Services.ServicesModule" 10:14:06.910 
36.  AspNetPipelineLeave Data1="DotNetNuke.HttpModules.Services.ServicesModule" 10:14:06.910 
37.  NOTIFY_MODULE_END ModuleName="Services", Notification="BEGIN_REQUEST", fIsPostNotificationEvent="false", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910 
38.  NOTIFY_MODULE_START ModuleName="IsapiFilterModule", Notification="AUTHENTICATE_REQUEST", fIsPostNotification="false" 10:14:06.910 
39.  NOTIFY_MODULE_END ModuleName="IsapiFilterModule",Notification="AUTHENTICATE_REQUEST",fIsPostNotificationEvent="false", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910
40.  NOTIFY_MODULE_START ModuleName="BasicAuthenticationModule",Notification="AUTHENTICATE_REQUEST",fIsPostNotification="false" 10:14:06.910 i AUTH_START AuthTypeSupported="Basic" 10:14:06.910
 1. i AUTH_END  10:14:06.910 
 2.  NOTIFY_MODULE_END ModuleName="BasicAuthenticationModule", 
Notification="AUTHENTICATE_REQUEST", fIsPostNotificationEvent="false", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910
 3.  NOTIFY_MODULE_START ModuleName="WindowsAuthenticationModule", Notification="AUTHENTICATE_REQUEST", fIsPostNotification="false" 10:14:06.910
 4. i AUTH_START AuthTypeSupported="NT" 10:14:06.910
 5. i AUTH_END  10:14:06.910
 6.  NOTIFY_MODULE_END ModuleName="WindowsAuthenticationModule", Notification="AUTHENTICATE_REQUEST", fIsPostNotificationEvent="false", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910
 7.  NOTIFY_MODULE_START ModuleName="AnonymousAuthenticationModule", Notification="AUTHENTICATE_REQUEST", fIsPostNotification="false" 10:14:06.910
 8. i AUTH_START AuthTypeSupported="Anonymous" 10:14:06.910
 9. i AUTH_REQUEST_AUTH_TYPE RequestAuthType="Anonymous" 10:14:06.910
 10. i AUTH_SUCCEEDED AuthType="NT", NTLMUsed="false", RemoteUserName="", AuthUserName="", TokenImpersonationLevel="ImpersonationImpersonate" 10:14:06.910
11. i USER_SET AuthType="", UserName="", SupportsIsInRole="true" 10:14:06.910
12. i AUTH_END  10:14:06.910
13.  NOTIFY_MODULE_END ModuleName="AnonymousAuthenticationModule", Notification="AUTHENTICATE_REQUEST", fIsPostNotificationEvent="false", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910 
14.  NOTIFY_MODULE_START ModuleName="IsapiFilterModule", Notification="AUTHENTICATE_REQUEST", fIsPostNotification="true" 10:14:06.910 
15. i FILTER_AUTH_COMPLETE_START  10:14:06.910 
16. i FILTER_AUTH_COMPLETE_END  10:14:06.910 
17.  NOTIFY_MODULE_END ModuleName="IsapiFilterModule", Notification="AUTHENTICATE_REQUEST", fIsPostNotificationEvent="true", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910 
18. i FILE_CACHE_ACCESS_START FileName="D:\DNN\DesktopModules\internalservices\API\controlbar\ToggleUserMode", UserName="IUSR", DomainName="NT AUTHORITY" 10:14:06.910
19. i FILE_CACHE_ACCESS_END Successful="false", FileFromCache="false", FileAddedToCache="false", FileDirmoned="true", LastModCheckErrorIgnored="true", ErrorCode="The system cannot find the path specified.
(0x80070003)", LastModifiedTime="" 10:14:06.910 
20.  NOTIFY_MODULE_START ModuleName="HttpCacheModule", Notification="RESOLVE_REQUEST_CACHE", fIsPostNotification="false" 10:14:06.910 
21. i OUTPUT_CACHE_LOOKUP_START  10:14:06.910
22. i OUTPUT_CACHE_LOOKUP_END Result="NOT_FOUND" 10:14:06.910
23.  NOTIFY_MODULE_END ModuleName="HttpCacheModule", Notification="RESOLVE_REQUEST_CACHE", fIsPostNotificationEvent="false", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910
24.  NOTIFY_MODULE_START ModuleName="UrlRoutingModule-4.0", Notification="RESOLVE_REQUEST_CACHE", fIsPostNotification="true" 10:14:06.910
25.  AspNetPipelineEnter Data1="System.Web.Routing.UrlRoutingModule" 10:14:06.910
26.  AspNetPipelineLeave Data1="System.Web.Routing.UrlRoutingModule" 10:14:06.910
27.  NOTIFY_MODULE_END ModuleName="UrlRoutingModule-4.0", Notification="RESOLVE_REQUEST_CACHE", fIsPostNotificationEvent="true", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910
28.  NOTIFY_MODULE_START ModuleName="StaticCompressionModule", Notification="MAP_REQUEST_HANDLER", fIsPostNotification="false" 10:14:06.910
29.  NOTIFY_MODULE_END ModuleName="StaticCompressionModule", Notification="MAP_REQUEST_HANDLER", fIsPostNotificationEvent="false", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910
30.  NOTIFY_MODULE_START ModuleName="ManagedPipelineHandler", Notification="MAP_REQUEST_HANDLER", fIsPostNotification="false" 10:14:06.910
31.  AspNetMapHandlerEnter  10:14:06.910
32. i HANDLER_CHANGED OldHandlerName="StaticFile", NewHandlerName="System.Web.Http.WebHost.HttpControllerHandler", NewHandlerModules="ManagedPipelineHandler", NewHandlerScriptProcessor="", NewHandlerType="System.Web.Http.WebHost.HttpControllerHandler, System.Web.Http.WebHost, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" 10:14:06.910
33.  AspNetMapHandlerLeave  10:14:06.910
34.  NOTIFY_MODULE_END ModuleName="ManagedPipelineHandler", Notification="MAP_REQUEST_HANDLER", fIsPostNotificationEvent="false", NotificationStatus="NOTIFICATION_CONTINUE" 10:14:06.910 
35.  NOTIFY_MODULE_START ModuleName="ManagedPipelineHandler", Notification="EXECUTE_REQUEST_HANDLER", fIsPostNotification="false" 10:14:06.910 
36.  AspNetPipelineEnter Data1="System.Web.ImplicitAsyncPreloadModule" 10:14:06.910 
37.  AspNetPipelineLeave Data1="System.Web.ImplicitAsyncPreloadModule" 10:14:06.910
38. i AspNetHttpHandlerEnter  10:14:06.910
39. i AspNetHttpHandlerLeave  10:14:07.363
40. r MODULE_SET_RESPONSE_ERROR_STATUS
Warning ModuleName="ManagedPipelineHandler", Notification="EXECUTE_REQUEST_HANDLER", HttpStatus="401", HttpReason="Unauthorized", HttpSubStatus="0", ErrorCode="The operation completed successfully.
(0x0)", ConfigExceptionInfo="" 10:14:07.363
41. i OUTPUT_CACHE_DISABLED  10:14:07.363
42.  NOTIFY_MODULE_COMPLETION ModuleName="ManagedPipelineHandler", Notification="EXECUTE_REQUEST_HANDLER", fIsPostNotificationEvent="false", CompletionBytes="0", ErrorCode="The operation completed successfully.
(0x0)"
iis-7
dotnetnuke
asp.net-4.5
asked on Stack Overflow Feb 8, 2013 by sachin • edited May 28, 2013 by NeverHopeless

7 Answers

6

I just had a similar issue tonight with DNN 7.2.1 but instead of a 401 I was getting a 404 on /DesktopModules/internalservices/API/controlbar/ToggleUserMode.

I remembered that I had just been actively developing a new project with the latest version of NewtonSoft.Json.dll. After I restored that file to the original that came with DNN 7.2.1 I was up and going again.

answered on Stack Overflow Feb 27, 2014 by Richard Edwards • edited Jan 11, 2017 by Mehdi Dehghani
0

I've seen this error being reported a bit lately, though I am not sure what causes this. It would appear to me that perhaps your ASP.NET settings are off for IIS. Could you try to aspnet_regiis -i from the commandline and see if that addresses the problem? You might also need to check the Windows configuration for IIS making sure all the proper options are enabled. I've taken a screenshot of my IIS installation options in Windows to see if that helps you.

IIS Settings

answered on Stack Overflow Feb 8, 2013 by Chris Hammond
0

This is s a fairly common issue in 7.x and unfortunately there are a few possible causes and some of them are still not fully understood. Please go through this thread and try the suggested fixes.

http://www.dotnetnuke.com/Resources/Forums/forumid/190/threadid/469106/scope/posts/threadpage/2.aspx

answered on Stack Overflow Feb 11, 2013 by EfficionDave
0

You could update your web.config and modify the modules tag with the following property.

<modules runAllManagedModulesForAllRequests="true" />

It worked for me. Hope this helps.

answered on Stack Overflow Feb 11, 2013 by Ryan Gunn
0

Had the same problem, tried all solutions from here.

Changing from Controlbar to Ribbonbar worked for me.

answered on Stack Overflow May 3, 2013 by tatigo • edited May 28, 2013 by NeverHopeless
0

If the problem is not resolved even after keeping the

<modules runAllManagedModulesForAllRequests="true" />

tag in web.config, then check whether the Newtonsoft.Json.dll is present in your Dotnetnuke's bin folder.

Try with this, it works!

answered on Stack Overflow May 28, 2013 by Rajesh kumar • edited May 28, 2013 by NeverHopeless
0

Go to host-settings, changing from Controlbar to Ribbonbar worked for me.

answered on Stack Overflow May 8, 2014 by MattOpen

User contributions licensed under CC BY-SA 3.0