IIS HTTP Error 500.19

29

I have installed IIS on my computer for the first time (until now I have worked with the express version), but it's not working properly. When I try to hit a page, it returns this error, which I do not know how to resolve:

Error Summary
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.
Detailed Error Information
Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x8007000d
Config Error
Config File \?\D:\2008\abcd.Website\web.config
Requested URL http : // localhost:80/abcd.Website

Physical Path D:\2008\ManagerAnticriza.Website
Logon Method Not yet determined
Logon User Not yet determined

Can anyone help me? Is there a way I need to configure IIS after installing it?

asp.net
iis
asked on Stack Overflow Jul 3, 2012 by user1482442 • edited Dec 12, 2014 by Nathan Strutz

5 Answers

57

This issue took me the best part of a day to figure out, as I had the exact same code working on another machine in the office.

It turns out that I was missing some features in IIS, and that the web.config I had carried down was looking for these features. I was missing both authentication features and the URL Rewrite module, and as a result IIS believed my web.config was malformed.

There are similar answers across the Internet that mention the URL Rewrite module, so I'd look there first.

answered on Stack Overflow Mar 8, 2013 by Mike B
4

installing iis rewrite module helped me here.

The requested page cannot be accessed because the related configuration data for the page is invalid error

-Naval

answered on Stack Overflow Jul 29, 2014 by indolentdeveloper • edited May 23, 2017 by Community
1

None of the solutions I'd seen worked for me but I eventually pinned it down to a clash between WSUS (Windows Server Update Service) and the way it was defining compression. My application pool needed to allow 32 bit applications and that was causing the trouble. In my case the module listed in the error message was the DynamicCompression module and I found the solution here so I'm posting it in case it helps anyone else.

https://community.sophos.com/kb/en-us/111319

answered on Stack Overflow Feb 8, 2018 by Mordy
0

because the related configuration data for the page is invalid

This is because your web.config is not well formatted, or did not have the correct permissions to be readed.

Error details: http://support.microsoft.com/kb/942055

answered on Stack Overflow Jul 3, 2012 by Aristos
0

Try changing the App Pool to v2.0

See here

answered on Stack Overflow Dec 29, 2016 by Lawrence Ngetich

User contributions licensed under CC BY-SA 3.0