Cannot console into VMs in Hyper-V

2

When I attempt to view the console of a VM in Hyper-V, I get the following messages:

Video remoting was disconnected

and

Could not connect to the virtual machine. Try to connect again. If the problem persists, contact your system administrator. Would you like to try connecting again?

I have seen many "fixes" and tried all of them. However, after doing a lot of digging, I did finally find a way to turn on logging and I am seeing errors. Does anyone recognize these?

Things I have tried:

  • Rebooting
  • Uninstalling Hyper-V and resinstalling
  • Doing a Refresh on my Windows 10 machine (Hyper-V server) (This allowed it to work for a day then next day doing the same thing)
  • Verified IPv6 was enabled. Then found it was disabled via GPO, so I moved it to an OU that did not have GPO applied, created a GPO that turns it on, gpupdate /force and reboot
  • Disabled all Firewalls/Antivirus
  • Opened vmconnect.exe as admin manually
  • Compared GPOs/Security settings with my home instance of Hyper-V that works
  • Turned off Enhanced session Mode
  • Turned off RemoteFX
  • Deleted VM and recreated
  • Tried just a VM without any ISO, or OS, or anything bootable other than BIOS
  • Disconnected VM from vSwitch

I apologize ahead of time for all the logs. Please let me know if you need any more info and thanks for helping me!

Logs

VMConnect_Trace_20180511125822

Tracing Hyper-V Client version: 10.0.0.0. Rough build date (virtman file written): 04/29/2018 03:56:46

2018-05-11 12:58:23.435 [01] USER_ACTION_INITIATED VmConnect RdpViewerControl:ConnectCallback() Connecting with server full name: ET1SYS23 to RDP port 2179
2018-05-11 12:58:35.035 [01] USER_ACTION_INITIATED VmConnect RdpViewerControl:ConnectCallback() Connecting with server full name: ET1SYS23 to RDP port 2179
2018-05-11 12:58:37.211 [01] USER_ACTION_INITIATED VmConnect RdpViewerControl:ConnectCallback() Connecting with server full name: ET1SYS23 to RDP port 2179
2018-05-11 01:00:26.173 [01] USER_ACTION_INITIATED VmConnect RdpViewerControl:ConnectCallback() Connecting with server full name: ET1SYS23 to RDP port 2179
2018-05-11 01:09:33.589 [01] USER_ACTION_INITIATED VmConnect RdpViewerControl:ConnectCallback() Connecting with server full name: ET1SYS23 to RDP port 2179
2018-05-11 01:10:01.123 [01] ERROR VmConnect RdpViewerControl:Deactivate() QueryInterface for IOleInPlaceObject on the Rdp Control failed.

Event Log (Microsoft-Windows-Hyper-V-VMMS-Admin)

    The required GPU resources could not be accessed. This server cannot run as a RemoteFX host without a GPU. Verify that the GPU is correctly installed.

    Cannot load a checkpoint configuration: The process cannot access the file because it is being used by another process. (0x80070020). (Checkpoint ID FD216B1C-2BB2-48A2-966C-C97D2853094D)

    Cannot load a checkpoint configuration: The process cannot access the file because it is being used by another process. (0x80070020). (Checkpoint ID FD216B1C-2BB2-48A2-966C-C97D2853094D)

    The required GPU resources could not be accessed. This server cannot run as a RemoteFX host without a GPU. Verify that the GPU is correctly installed.

Event Log (Microsoft-Windows-Hyper-V-VMMS-Analytics)

vm\service\resmgr\video\synth3dvideopoolrepository.cpp(884)\vmms.exe!00007FF639018178: (caller: 00007FF63900CD0F) Exception(1) tid(2728) 80004005 Unspecified error

[Synth3dPhysicalGPUManager::InitGpuStates()@1356] Caught exception: Unspecified error (0x80004005)

vm\service\fr\frctutilities.cpp(2223)\vmms.exe!00007FF63910DF69: (caller: 00007FF6394A6B0E) Exception(2) tid(ebc) 80070002 The system cannot find the file specified.

[FrCtUtilities::UpdateFRCTFilesTime()@2226] Caught exception: The system cannot find the file specified. (0x80070002)

Event Log (Microsoft-Windows-Hyper-V-Worker-Admin)

The virtual machine Ubuntu 18.04 cannot load device Microsoft Synthetic Display Controller because there are no mutually supported protocol versions. The server version is 3.5 and the client version is 3.2 (Virtual machine ID B4714427-9B5E-4CD1-AE7D-5020D643EC55).

'Ubuntu 18.04' started successfully. (Virtual machine ID B4714427-9B5E-4CD1-AE7D-5020D643EC55)

Event Log (Microsoft-Windows-Hyper-V-Worker-Analytics)

[Virtual machine  - ] [PIC ] Using unhandled command 3

[Virtual machine B4714427-9B5E-4CD1-AE7D-5020D643EC55] onecore\vm\ic\framework\icendpoint.cpp(1279)\vmiccore.dll!00007FF871CBCC3F: (caller: 00007FF871CBCEE8) LogHr(1) tid(24d4) 8007000D The data is invalid.
    Msg:[Truncated or partial message header] 

[Virtual machine B4714427-9B5E-4CD1-AE7D-5020D643EC55] onecore\vm\ic\framework\icendpoint.cpp(1288)\vmiccore.dll!00007FF871CBCCE5: (caller: 00007FF871CBCEE8) LogHr(2) tid(24d4) 8007000D The data is invalid.
    Msg:[Processing failed with unprocessed portions; bytesRemaining = 8] 

[Virtual machine B4714427-9B5E-4CD1-AE7D-5020D643EC55] onecore\vm\ic\framework\icendpoint.cpp(1288)\vmiccore.dll!00007FF871CBCCE5: (caller: 00007FF871CBCEE8) LogHr(4) tid(2520) 8007000D The data is invalid.
    Msg:[Processing failed with unprocessed portions; bytesRemaining = 12] 

[Virtual machine B4714427-9B5E-4CD1-AE7D-5020D643EC55] onecore\vm\ic\framework\icendpoint.cpp(1279)\vmiccore.dll!00007FF871CBCC3F: (caller: 00007FF871CBCEE8) LogHr(5) tid(2454) 8007000D The data is invalid.
    Msg:[Truncated or partial message header] 

[Virtual machine B4714427-9B5E-4CD1-AE7D-5020D643EC55] onecore\vm\ic\framework\icendpoint.cpp(1288)\vmiccore.dll!00007FF871CBCCE5: (caller: 00007FF871CBCEE8) LogHr(6) tid(2454) 8007000D The data is invalid.
    Msg:[Processing failed with unprocessed portions; bytesRemaining = 12] 

[Virtual machine B4714427-9B5E-4CD1-AE7D-5020D643EC55] Unable to find a connection in the connection map.
hyper-v
hyper-v-server-2016
asked on Server Fault May 11, 2018 by alexander7567

1 Answer

0

I had similar problem and played all of these that you listed - finally I found that probably my network gateway blocked communication through some necessary port (no idea which) - however when I connected to the host machine via a virtual-wifi-network-switch it worked and when I connected via virtual-LAN-switch it worked. Hope it helps.

answered on Server Fault Sep 12, 2018 by user487280

User contributions licensed under CC BY-SA 3.0